DSA-2496 mysql-5.1 - several vulnerabilities

Due to the non-disclosure of security patch information from Oracle,
we are forced to ship an upstream version update of MySQL 5.1.
There are several known incompatible
changes, which are listed in /usr/share/doc/mysql-server/NEWS.Debian.gz.