DSA-2519 isc-dhcp - several vulnerabilities

Several security vulnerabilities affecting ISC dhcpd, a server for
automatic IP address assignment, have been discovered. Additionally, the
latest security update for isc-dhcp, DSA-2516-1,
did not properly apply the patches for
CVE-2012-3571
and
CVE-2012-3954.
This has been addressed
in this additional update.