(Black) Friday's security updates

Debian has updated trousers (denial of service).

Fedora has updated libsocialweb (F16, F17; information disclosure), pcp (F16, F17; insecure temporary files), and xen (F16,
F17; multiple vulnerabilities).

openSUSE has updated lighttpd (denial of service).

Red Hat has updated java-1.4.2-ibm (multiple vulnerabilities).